Image Production Step by Step Reference

The Collaboratory Project « Northwestern University

After capturing an image with a flatbed or a slide scanner, you will typically apply the
following techniques to it:

¢ Crop page 3
e Scale page 4
e Adjust brightness and contrast page 6
® Adjust color page 13
e Sharpen page 15
e Save in the appropriate file format page 17

In Adobe Photoshop 4.0 there are several ways to accomplish each of these tasks. We will
describe some of these ways in this tipsheet, offering you both a simple but somewhat
restricted way and a more complex but versatile way to accomplish each step. In some
instances more advanced techniques will also be explained. Most of these techniques are not
exclusive to Photoshop: all the basic functions for preparing an image be found in any image
production application.

This reference document is geared toward preparing images for display on a monitor,
typically in a page on the World Wide Web. While the techniques explained here are also
applicable to preparing images for print media, critically important issues such as resolution
and color correction are left out.

Before you begin you may want to calibrate your monitor. This helps to ensure that the full
range of brightness and color values represented in a file display consistently from one
editing session to another. See the Photoshop manual for details (Chapter 5: Reproducing
Color in the Photoshop 4 manual). Even if you don’t calibrate your monitor, keep the
following in mind:

e Work with consistent ambient light. As with television, lower ambient light may
provide better contrast on your monitor.

e Use a uniform gray background on your monitor, not a pattern or a picture.

e Adjust the brightness and contrast on your monitor so you see a full range of grays,
with black blacks and white whites (just like in a laundry detergent commercial).

Getting Started

Launch the Adobe Photoshop application. Once it is open, you may need to do some
preliminary adjustments to set up the image editing environment. We assume that you will
be working with images you want to display on a computer monitor, for example, on the
World Wide Web. Accordingly, the dimensions of images should be measured in pixels. You
should also work with 24-bit images (millions of colors).

1. If the Info Palette is not visible, from the Window choose Show Info. The Info Palette
appears.
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Figure 1: The Info Palette

From the File menu Preferences submenu choose Units and Rulers.... The Units and

Rulers dialog box appears.

Preferences
Units & Rulers -
— ~
ulers
Column Size
width: [15 | [picas  [~] Next
Gutter: [1 | [ picas  [+]
Point/Pica 5ize
® PostScript {72 points/inch)
) Traditional {72.27 points/inch)

Figure 2: The Units and Rulers Dialog

Press on the Rulers Units popup menu in the dialog box and select pixels. Click OK.
The ruler units are set to pixels and the Units Preferences dialog boxes closes. The Info
Palette now show units in pixels.

From the File menu choose Open... and open the image you want to adjust.

If your image does not use 24-bit color (millions of colors), from the Image menu
Mode submenu choose RGB Color. The image is set to 24-bit RGB color mode.

Note: Many image processing operations work only with 24-bit or 16-bit “direct color”
images, or with 8-bit grayscale images. Unlike 8-bit “indexed color” images which use a
numerically indexed palette of 256 colors, such images store the actual values for each
pixel as a numerical value. When you capture your image with a scanner or other
imaging device, be sure to capture it as a 24-bit color image. Most flatbed and slide
scanners default to 24-bit color when you specify that you are capturing a color image.
When you are finished working with the image you can save it with 8 bits or less of color
resolution, if that is appropriate.
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Cropping and Adjusting the Resolution of an Image

In most scanned images you will only be interested in one selected area of the image. The
rest can be trimmed away. In addition, scanned images are captured at a resolution
determined by the scanning device, which may not be the resolution you need.

1. 1In the Adobe Photoshop Tools Palette click on the Selection Tool (dotted rectangle in
the upper left corner of the palette).
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Figure 3: The Selection Tool

2. Drag a selection rectangle around the area you are interested in the image. The
selection is highlighted by a rectangle of “crawling ants.” You may have to make the
selection a few times to get exactly the area you want.

3. From the Image menu choose Crop. Everything outside the selection is deleted.

Now we’ll change the resolution of the image, if necessary. Resolution in this case refers to
the number of pixels per linear inch. This value was set when the image was first scanned. For
example, many flatbed document scanners scan at 300 pixels per inch. You usually can’t tell
what the resolution of an image is just by looking at it on a monitor. Monitors simply show
you every pixel in the image at whatever the resolution of the monitor is set to. 72 pixels per
inch is considered the default resolution for a computer monitor. When you print an image,
the resolution does become apparent. A 300 pixel per inch image prints much smaller than a
72 pixel per inch image, if both have the some dimension as measured in pixels.

4. From the Image menu choose Image Size.... The Image Size dialog box appears.

5. If the resolution of the image is already 72 pixels per inch, click the Cancel button:
you’re finished with this step. Otherwise, go on to the next step.

6. Uncheck the Resample Image check box at the bottom of the Image Size dialog box.
7.  Set the Resolution popup menu to pixels/inch.

8. Type “72” as the resolution, and then click OK. The image will not appear to change at
all, but in fact you have given it a new resolution. The resolution will be stored with the
file when you save it.
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Image Size

Pixel Dimensions: 430K
Width: 494 pixels
Height: 297 pixels
Print Size:
width: [6.861 | [inches  [+]
Height: [4¢125 | [inches [~] g
Resolution: |I"2]‘I | [ pixelssinch |~

Constrain Proportions
] Resample Image: [ Bicubic |v]

Figure 4: The Image Size Dialog Box

Scaling an Image

You can scale an image with the Image Size... command. This technique is particularly useful
if you want to scale a series of images—for example, images from a digital camera—all by the
same amount, because you can use Photoshop’s Actions palette and batch-processing
capabilities to automate your task. Explaining how to use the Actions palette lies beyond the
scope of this document, but here’s how to scale an image with the Image Size... command:

1. From the Image menu choose Image Size.... The Image Size dialog box appears.

2. In the Image Size dialog box check the Constrain Proportions and Resample Image
checkboxes. Set the Resample Image popup menu to Bicubic. These settings will scale
horizontal and vertical dimensions by the same amount and provide very smooth
blending of pixels.

Image Size

Fixel Dimensions: 48K {was 192K}

Width: 256 | [pixels  [+] :l
E’I

Cancel
Height: [192 | [pixels  [+]
Auto...
Print Size:
Width: |50 | [percent [+]
Height: |50 | [percent [+] :l
Resolution: |?2 | [ pixelssinch |~

Constrain Proportions
Resample Image: [ Bicuhic |L,

Figure 8: The Image Size dialog box set to scale an image by 50% horizontally and vertically
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3. Enter the width and height values for your output image. The values shown here are in
percentage. Click OK. The dialog box closes and your image is resized by the values
you entered for width and height.

Alternative Method:
Cropping , Resolution, Rotation and Scaling With the Cropping Tool

Scanned images may need to be rotated to correct skewed placement on the scanner. While
we could do this with the Rotate Canvas...:Arbitrary... command in the Image menu, here’s a
more versatile way to do cropping, resolution adjustment, rotation and scaling in a single
operation with Photoshop’s Cropping Tool. While the previous techniques for these
operations can be found in just about any image editing application, the Cropping tool’s
power is unique to Photoshop.

1. 1In Tools palette hold the mouse button down over the Selection tool to show the
popup menu and select the Cropping tool from the menu. The selected tool changes to
the Cropping tool.

1 8

Figure 5: The Cropping Tool

2. If the Cropping Tool Options window is not visible, double-click on the Cropping tool
in the Tools palette. The Cropping Tool Options Window appears.

| Naviga1 I| Cropping Tool Options | »

[=]Fixed Target Size Front Irnage

width: [320 | [pixels  [~]
Height: [240 pixels vl
Resolution: |72 | [ pixelsfinch [ -]

Figure 6: The Cropping Tool Options Window

3. Check the Fixed Target Size checkbox. Enter pixel values for Width and Height. Enter
72 pixels/inch as the Resolution. The Cropping tool will now work with the values you
have set. You can enter width and leave height blank to fix width but not height.

4. Click and drag in the image to select the area you are interested in cropping. A
selection box appears around the area, with control boxes at the corners and sides.

5. Click and drag the control boxes to change the area you want to crop. Click and drag
inside the cropping box to move it. To rotate the image, move the cursor outside the
cropping selection and then click and drag.

6. DPress the Enter key to execute the cropping. The picture is cropped, scaled and rotated
and its resolution changes to 72 pixels per inch.
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Changing the Brightness and Contrast of an Image

There are several methods for changing brightness and contrast. We’ll list them here from
simplest to most complex. They all appear in the Image menu’s Adjust submenu. The
Brightness and Contrast... command provides the simplest adjustment. The Variations...
command is almost as easy to use, but requires lots of space on your monitor, and functions
best with plenty of memory. Neither of these commands tells you what values are really
present in your image, which the Levels... command does. It is often the best command to
use to adjust an image, and not overly complicated. If you need to adjust specific ranges of
values (for example, brighten up only in the darkest tones) the Curves... command may serve
you best, but it provides a dizzying array of possible effects. Both the Levels... command and
the Curves... command can be used automatically: in effect, you ask Photoshop to look at
the image and adjust it for you. For images with a broad range of values this can often be
effective, at least in providing you “ballpark” settings.

If you want to restrict your adjustments of brightness and contrast to a specific region of an
image, select the region with Photoshop’s selection tools (marquee, lasso, or magic wand)
before adjusting brightness or contrast. You may also find it useful to feather the selection
(Select menu, Feather... command) to give it “fuzzy” edges.

Note: If you are working on a Macintosh computer, you may want to adjust the brightness
slightly high to improve the image quality when it is dsplayed on PC-comapatible
computers, which have a darker display.

Adjusting Brightness and Contrast
With the Brightness/Contrast Command

1. From the Image menu Adjust submenu choose Brightness and Contrast. The
Brightness/Contrast dialog box appears.

Brightness/Contrast

Brightness:

. b

Contrast: E
= Preview

Figure 9: The Brightness/Contrast Dialog box

2. Check the Preview checkbox. Drag the triangular sliders for Brightness and Contrast.
The brightness and contrast of your image change. Dragging the sliders to the right
increase brightness and contrast, dragging them to the left decreases brightness and
contrast. The image changes to give a preview of the results of your settings.

3. Click OK. The brightness and contrast settings are applied to the image.
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Alternative Method:
Adjusting Brightness and Contrast With the Variations Command

The Variations... command permits you to adjust the brightness, contrast and color of an
image with interactive preview images. Here we’ll just tell you how to adjust the brightness
and contrast. See the next section on adjusting color for more information on how to use the
Variations command.

1. From the Image menu Adjust submenu choose Variations.... The Variations dialog box
appears.

2. In the Variations dialog box click on the Midtones radio button in the top right hand
corner of the dialog box. Click on the Lighter image to lighten midtones. Click on the
Darken image to darken the midtones. The center image changes to reflect your
adjustments.
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Figure 10: The Variations dialog box

2. Similarly, click on the Shadows and Highlights radio buttons and adjust the shadows
and highlights in the image. Tip: check the Show Clipping checkbox to see where pixels
would be lightened to white or darkened to black. The clipped pixels will show as
inverted black or white pixels in the preview images.

3. Click OK. The adjustments specified in the Variations dialog box are applied to the
image.

Advanced (Recommended) Method:
Adjusting Brightness and Contrast With the Levels Command

One serious drawback to both the Brightness and Contrast and the Variations command is
that they assume that the image on your monitor is the best guide to how to adjust the
image you are working with. This is not necessarily the case. In a bright environment the
apparent contrast of a monitor decreases. Also, you may have brightness and contrast
settings on your monitor that do not adequately show the full range of values in the image.
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Finally, monitors on different platforms have different gamma settings—gamma settings
determine how the numeric values in a graphics file are mapped onto actual intensities of
light. PC monitors are darker than Macintosh monitors, while some UNIX workstation
monitors are brighter. The Levels... command is useful precisely because it shows graphically
how the actual numerical values in an image are distributed.

1. From the Image menu Adjust submenu choose Levels.... The Levels dialog box appears.

Levels
Channel: [ RGB -]
put Levels: [ Cancel

Load

Save

Auto

- ..ul‘hw
F = 2

Output Levels: [0 |
) . Preview

N
B
N

Figure 11: The Levels dialog box

The Levels dialog box has many capabilities. We are only going to look at a few of them.
Note that the dialog box is organized into sections:

e Starting at the top we have the Channel popup, which you won’t need to change. It
should be set to RGB for color images. It isn’t used for grayscale images.

® Below the Channel popup are the Input levels fields and a graph, called a histogram,
which has three triangular sliders along its bottom edge. The sliders can be used to
change the values in the Input levels fields. The histogram shows you what values are
actually present in your image. Values range from black (0) on the left of the histogram
to white (255) on the right of the histogram, with all shades of gray in between. The
gray triangle marks the middle gray point. The vertical lines in the graph indicate how
many pixels in the image have a particular value.

A histogram can provide you with a lot of information about an image. For example, if
most of the graph is towards the black end of the scale, you know the image is dark. If
values are concentrated in the middle the image has low contrast. The histogram above
corresponds to an image that is fairly bright but which could have improved contrast.

At the bottom of the dialog box are the output levels entry fields, a grayscale bar, and
two triangular sliders which can be used to adjust the numeric values in the fields.

2. Check the Preview checkbox in the Levels dialog box. Any changes you make to the
sliders will now be previewed in the image you are working with.
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3. Drag the black triangular slider under the histogram to the right. The image gets
darker.

4. Drag the white triangular slider under the histogram to the left. The image gets
brighter.

5. Return the black and white triangular sliders to their original settings and then move
the gray triangular slider to the left or to the right. The image gets brighter when you
move the gray slider to the left and darker when you move it to the right.

6. Click the Auto button. Unless the image you are using already has a statistically
“correct” distribution of values, you will see the image and the histogram change. If you
like the results of clicking the Auto button, you can click on the OK button now.
Otherwise, continue.

7. Hold down the option key (Macintosh) or Alt key (PC) and click the Reset button,
which appears in place of the Cancel button when you hold down the modifier key.
The histogram reverts to its original settings.

8. Move the black triangular slider under the histogram to the right until it rests under
the leftmost vertical lines in the histogram. The images becomes darker.

9. Move the white triangular slider under the histogram to the left until it rests under the
rightmost vertical lines in the histogram. The image becomes lighter.

10. If the histogram displays more values to the left of the gray triangular slider, move the
slider to the left. It the histogram displays more values to the right, move the gray
triangular slider to the right. The distribution of midtones in the image changes.

11. Continue adjusting the sliders until the results seem to improve the image, then click
OK. The Levels settings are applied to the image.

In some instances you may want to darken or lighten all the values in a image. This is
particularly useful if you plan to put black or white type on top of it. You can experiment
with the Output Levels sliders on the bottom edge of the Levels dialog box to adjust the
range of values present in an image.

Advanced Method:
Adjusting Brightness and Contrast With the Curves Command

When there are specific ranges of values in an image that need to be adjusted while the other
values stay more or less the same, the Curves command can be very useful. Essentially it
allows you to change any value in the original image to any other arbitrary value by drawing
a curve that represents how input values correspond to output values. In addition to
adjusting brightness and contrast, the Curves command can solarize, posterize, and create
other weird effects. Watch out!

1. Double-click on the Eyedropper Tool in the Tools Palette. The Eyedropper Options
Palette opens.

2. Set the Sample Size popup menu in the Eyedropper Options to 3 x 3 Average. This
setting will provide the eyedropper tool with readings of the colors in the image which
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are less affected by individual pixels. The Curves command makes use of the eyedropper
tool.

3. From the Image menu Adjust submenu choose Curves.... The Curves dialog box

appears.

Curves ==——————HI=

- Channel: | RGE 0 w | —

Cancel

Load...

DI.II:E:: [ Preview

Figure 12: The Curves dialog box

The Curves dialog box contains a graph with a diagonal line which shows the relation of
input values to output values. You can redraw the graph to change the output values. Under
the graph there is a grayscale bar. Under the bar, there are two drawing tools, a curve tool
and a pen tool. There are various other buttons and tools.

4. In the Curves dialog box, check the Preview checkbox.

5. Click on the gray scale bar below the curve graph so that the light values are on the
left. The graph now measure values in percent.

6. Click on the curve drawing tool to select it. Move the cursor over the image and press
the mouse button down over different areas of the image. The cursor displays as an
eyedropper. A circle appears on the graph along the diagonal line, indicating which part
of the line controls the pixels the tip of the cursor is over.

By moving the cursor over an area you want to change, you can find the part of the curve
that will affect the particular range of values in that area. The steps that follow are only an
exercise to show you a little about the way the Curves command works.

7. Move the cursor on the line in the Curves graph to the point where the input and
output values indicate 75%. Click on the line to create a point, and drag the point
down to where input reads 75% and output reads 62%. The graph line changes to a
bowed curve, and the image gets lighter.

8. Click on the graph at input 50% and output 50%, and again at 25%/25%. Two new
points appear on the curve, pulling part of it back towards its original diagonal shape.
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The light areas regain their original values. By changing the shape of the curve you have
now sclectively lightened the darkest values in the image, and left the lighter values
relatively unchanged. You can move the cursor along the curve to see the relation of the

input values in your image to the output values controlled by the curve.

Curves =————[01=

- Channel: RGB 0w | —

_f'/
DI.II:E:: ?Zg (<] Preview

Figure 13: The Curves dialog box after adjusting

9. Experiment with the Curves command to see its effects. There isn’t room in this
document to explain all the Curves command can do, but here are a few samples:

i‘ll‘

Figure 15: Curves for low contrast and high contrast operations

Both the Levels and the Curves commands can save and load settings. This is particularly
useful when you have a whole series of images that have similar requirements for brightness
and contrast enhancement. Because Curves command allows you to reassign the input values
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of every single pixel in an image to literally any output value you choose, you can create
many special effects with it, as with the following sample blokes (some curves were drawn
with the Curves’ pencil tool):

Figure 17: The results of these curves on some sample blokes:
Posterization, Solarization, and a Smooth Zebra effect
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Adjusting the Color of an Image to Remove a Color Cast

Frequently a color image from a photographic source will have a noticeable tint affecting the
entire image. This undesirable effect is called a color cast. While there are many tools in
Photoshop which could adjust the over all tonality of an image to remove a color cast,
including the Levels... and Curves... commands, the Variations... command and the
Hue/Saturation... command work particularly well for this common problem. For extreme
color casts you can also use the Color Balance command.

Adjusting Color with the Variations Command

The Variations... command permits you to adjust the brightness, contrast and color of an
image with interactive preview images. We’ll assume your image has a greenish cast as the
result of being shot with daylight film under fluorescent lights.

1. From the Image menu Adjust submenu choose Variations.... The Variations dialog box
appears.

2. In the Variations dialog box click on the Midtones radio button in the top right hand
corner of the dialog box. Click the “More Magenta” adjustment (opposite to the More
Green adjustment). The center image changes to reflect your adjustments.
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Figure 10: The Variations dialog box

2. Similarly, click on the Shadows and Highlights radio buttons and adjust the shadows
and highlights in the image. You can vary the amount of adjustment on each step with
the Fine to Coarse control.

3. Click OK. The adjustments specified in the Variations dialog box are applied to the
image.
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Adjusting Color with the Hue/Saturation Command

For the following instructions, we’ll assume your image is too warm (a red or yellow cast), as
often happens with digital cameras under incandescent lighting.

1. 1. From the Image menu Adjust submenu choose Hue/Saturation.... The

Hue/Saturation dialog box appears.

Hue/5aturation
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Figure 18: The Hue/Saturation Dialog Box

2. Click on the “M” for magenta radio button. Drag the Saturation slider to the left. The

magenta tones in the image become less vivid.

3. If other colors in the image need adjustment, select the appropriate radio button and
adjust their saturation or lightness. Click OK to save your changes.

Hint: In general, you won’t need to adjust the Hue. In particular, adjusting hue with the
Master radio button selected radically changes all the colors in your image—but maybe you

want green people on a purple lawn!

Adjusting Color with the Color Balance Command

The Hue/Saturation command is particularly effective for comparatively fine adjustments in
color. For more coarser control color you may find the Color Balance command more
effective. In many respects the Color Balance command works the same way as the Variations

command, but with a simpler interface.

1. 1. From the Image menu Adjust submenu choose Color Balance.... The Color Balance

dialog box appears.

Color Balance

Color Levels: E El

Cyan ' Red _Canl:el
Magenta : ' Green -
Yellow : ' Blue Preview

(O Shadows & Midtones O Highlights
Preserve Luminosity

Figure 19: The Hue/Saturation Dialog Box
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2. Click the Preview and Preserve Luminosity checkboxes. The Preserve Luminosity
checkbox maintains the brightness and contrast of your image as you change its color.

3. Click on the Midtones button and drag the Cyan-Red, Magenta-Green or Yellow-Blue
sliders. The colors in the image change along the color axis represented by each slider.

4. Similarly, adjust the shadows and highlights of your image.
5. Click OK to apply your settings to the image.

Sharpening an Image

Scanning and processing tend to blur the details in an image. When you are through
working on an image you will usually want to sharpen it. Sharpening improves most
photographic images. It may not be necessary for images such as diagrams and charts, which
are best enhanced with the adjusting contrast and brightness. There are several commands to
do sharpening, all in the Filter menu: Sharpen, Sharpen More, and Unsharp Mask. The
Sharpen and Sharpen More filters sharpen all pixels in your image equally. The Unsharp
Mask command will sharpen edges more than low contrast details.

Sharpening an Image with the Sharpen or Sharpen More Command

1. From the Filter menu, Sharpen submenu, choose Sharpen or Sharpen More. The image
becomes sharper, minimally in the case of the Sharpen command and quite noticeably
in the case of the Sharpen More command.

Of these two commands, Sharpen More will have the most dramatic effect. Executing it
repeatedly can cause the image to become very grainy. It may also sharpen subtle detail that
you want to remain subtle. The Unsharp Mask... command preserves subtle detail.

Sharpening an Image with the Unsharp Mask... command

1. From the Filter menu, Sharpen submenu, choose Unsharp Mask.... The Unsharp Mask
dialog box appears.

2. In the Unsharp Mask dialog box set the Amount to 80%, the radius to 1.0 pixels, and
the Threshold to 3 pixels. The image becomes slightly sharper where edges meet. Note
in the sample image where the edge of the mountains meets the sky.

Image Production Step by Step Reference Page 15 of 19
The Collaboratory Project Copyright © 1997 by the Trustees of Northwestern University



Unsharp Mask
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Figure 19: Unsharp Mask dialog box
3. Click OK to apply the values you have set to your image.

The values suggested here are good approximations for most images that will display on a
monitor. The Amount value controls the amount of contrast enhancement. Values from 50%
to 200% are usually effective. The Radius value controls how many pixels on either side of an
edge get enhanced. For images that will display on a monitor the smallest detail is one pixel,
and that is usually the best value for the Radius setting. The Threshold value controls how
edges are defined. Setting it to a low value brings out all edges, while setting it higher
emphasizes only high contrast edges. About the maximum value you’d want for Threshold is
10 levels.
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Saving an Image for the World Wide Web

Once you have adjusted an image to your liking, you will need to save it in a format
appropriate for the World Wide Web. There are two image formats universally supported by
graphical web browsers like Netscape Communicator and Microsoft Explorer, GIF and JPEG.
Both are compressed file formats: they squeeze the image file into a small space. JPEG
achieves more compression than GIF, but only because it actually “throws out” some of the
data in an image file. Usually you don’t notice this “lossy” compression because it only
results in minor variations in color that are optically almost invisible, although they become
apparent as images are squeezed into very small space. You can set the amount of
compression you want in a JPEG file.

GIF (Graphics Interchange Format)

e Maximum of 256 colors (indexed color model, with a palette of colors)
¢ One color may be designated as transparent

e The GIF 89a file format supports animation

e Uses “lossless” compression

e Best format for text, diagrams, charts, flat art, buttons and ornaments

JPEG (Joint Photographic Experts Group)

e Millions of colors (direct color model)

e Permits user to set “quality,” which corresponds to amount of compression
e Uses “lossy” compression

e Best format for photographic images

Saving an Image in JPEG format

You image must be in 24-bit color (millions of colors) to be saved in JPEG format. See the
Getting Started section for instructions on how to change a file to 24-bit color.

1. From the File menu choose Save As.... The Save As dialog box appears.

2. Enter as a name for your file a single short word followed by a period and the three
letter extension “jpg,” i.e. “halloween.jpg” or “skeleton.jpg.” This extension is

essential for JPEG files on the World Wide Web.

3. From the Format popup menu choose JPEG. Click OK. The file format is set to JPEG.
The JPEG Options dialog box appears.

4. In the JPEG Options dialog box, from the Quality popup menu choose Medium. Set
Format Options to Baseline Standard and Click OK. Your image is saved as a JPEG file.

Note: See your Adobe Photoshop manual for an explanation of the other options.
Baseline Standard is the most universally supported option.
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Saving an Image in GIF Format

An image must be in indexed color format (256 or fewer colors in a palette) to be saved in
GIF format. We have assumed that you were using an image with millions of colors (24-bit
or 16-bit direct color), so here’s how to change it to 256 or fewer colors.

1. From the Image menu Mode submenu choose Indexed Color.... The Indexed Color
dialog box appears.

Indexed Color

Palette: | Adaptive |~]

Color Depth: | 8 bits/pixel [~]
Colors:

Options

Cancel

Figure 21: The Indexed Color dialog box

2. From the Palette popup menu choose Adaptive. From the Color Depth menu choose 8
or fewer bits/pixel, or enter a number into the Colors field. From the Options
submenu choose Diffusion.

An adaptive palette will select an optimal set of colors for representing an image. A
diffusion dither scatters pixels like pointillist dots to create an optical blend that further
improves image quality. In general, you should use as few colors as are necessary to
create a reasonably good quality image. Fewer colors results in smaller GIF files, which
are desirable for World Wide Web pages.

3. Click OK. The image is converted to the number of colors you specitied.
4. From the File menu choose Save As.... The Save As dialog box appears.

5. Enter as a name for your file a single short word followed by a period and the three
letter extension “gif,” i.e. “halloween.gif” or “skeleton.gif.” This extension is essential
for GIF files on the World Wide Web.

6. From the Format popup menu choose CompuServe GIF. Click OK. The GIF Options
Dialog appears.

7. In the GIF Options dialog click on Normal or Interlaced row order. Click OK. The file
is saved in GIF format. Interlaced row order will make your GIF file appear in several
animated bands when the file is accessed over a network by a Web browser.

Saving an Image in GIF 89a Format with a Transparent Color

You can also save files in GIF format with the GIF 89a Export... command in the File menu,
Export submenu. This command permits you to set one or more colors in an image to
transparent, so that the background of web pages will show through transparent color
regions.
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1. Prepare your image so you have filled all pixels that will be transparent with a color
that is not used anywhere else in the image.

2. Follow steps 1 through 3 in the previous section. You may need to retouch the
transparent areas of your image if you use a diffusion dither.

3. From the File menu Export submenu choose GIF89a Export.... The GIF89a Export
dialog box appears.
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Figure 22: The GIF89a Export dialog box

4. Select the GIF89a eye dropper tool and click on the transparent color in you image.
The transparent color turns to the default transparency index color (gray, usually). You
may click on more than one color, or click on colors in the palette in the dialog box.

5. Select Interlace if you want to save the image in interlaced format. Click OK The
image is exported as a GIF file. Note that your original file remains unchanged.
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